Aria G25

Acme-R4

Terra

Terra-R5

SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="*", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="*", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

FOX Board G20

Acme-R18

Aggiornato "(Acme-R18)" in /etc/issue e /etc/issue.net Disabilitato il w1 Abilitati i driver atheros Installato il firmware atheros

apt-get update al 25 ottobre 2011
apt-get install wireless-tools
apt-get clean

Aggiornati i link sulla pagina web di default

Acme-R16 (Mai pubblicata ma spedita a qualcuno)

Ripartito da R14 perche' R15 non consente il funzionamento di lighttpd

Inserito "exit 0" nello script /etc/cron.weekly/apt-xapian-index

"Linux Debian" invece che "Debian Lenny" nell'argomento title del tag img dell'immagine Debian sulla pagina Web di default

Aggiornato "(Acme-R16)" in /etc/issue e /etc/issue.net

apt-get update al 11 ottobre 2010

Cambiato il file /etc/udev/rules.d/70-persistent-net.rules in questo modo:

SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="*", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="*", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

Acme-R15

apt-get purge apt-xapian-index

Disabled the script in /etc/cron.weekly

"Linux Debian" invece che "Debian Lenny" nel title dell'immagine Debian sulla pagina Web

Aggiornato "(Acme-R15)" in /etc/issue e /etc/issue.net

Acme-R14

apt-get update al 31 agosto

apt-get upgrade al 31 agosto
apt-get install python-smbus
apt-get clean

Aggiornato "(Acme-R14)" in /etc/issue e /etc/issue.net

Acme-R13 (Non pubblicata)

apt-get update e upgrade al 25 agosto

apt-get clean
apt-get install htop

fstab con partizione /media/data montata swap disabilitato In /etc/lighttpd/lighttpd ridotti i processi fcgi Aggiunto "(Acme-R13)" in /etc/issue e /etc/issue.net Decommentato "Banner" in /etc/ssh/sshd_config

Acme-R12

Creata la directory /media/mmc_p1 Modificato /etc/fstab per montare la prima partizione SD

/dev/mmcblk0p2 / ext4 noatime 0 1                                               
/dev/mmcblk0p1 /media/mmc_p1 vfat noatime 0 1                                   
/dev/mmcblk0p3 none swap sw 0 0
proc /proc proc none 0 0

Aggiunto

/etc/init.d/foxg20_user_led
#! /bin/sh
### BEGIN INIT INFO
# Provides:          foxg20_user_led
# Required-Start:    
# Required-Stop:     
# Default-Start:     1 2 3 4 5
# Default-Stop:      0 6        
# Short-Description: Manage the user led PC7 on FOX Board G20
### END INIT INFO


PATH=/sbin:/usr/sbin:/bin:/usr/bin

. /lib/init/vars.sh
. /lib/lsb/init-functions

case "$1" in
    start)
    echo "User led as hearbeat"
    echo heartbeat > /sys/class/leds/user_led/trigger
        ;;
    restart|reload|force-reload)
        echo "Error: argument '$1' not supported" >&2
        exit 3
        ;;
    stop)
    echo "User led off"
    echo none > /sys/class/leds/user_led/trigger
        ;;
    *)
        echo "Usage: $0 start|stop" >&2
        exit 3
        ;;
esac

Creati tutti i link simbolici per i vari runlevel con il comando

insserv foxg20_user_led

apt-get install ppp